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Why should I care?

Antelope is one of the (but not the only!) ways of dealing 

with seismic data

AVO, AEIC, and IRIS/PASSCAL all use Antelope

Antelope has a rich set of libraries for manipulating 

seismic data via programming languages – c, FORTRAN, 

tcl/tk, perl, Matlab, and shell scripting



What is Antelope?

A suite of software for acquiring, archiving, 

databasing, and using seismic data

Two components:

Real time (Orb) system

Offline (archival) system

Entire short-courses have been taught on just 

the basics!

Antelope uses the Datascope relational 

database system



What is a (Datascope) database?

A way of organizing a collection of information into easily 

accessible format.

Structure:

Database

Table

Field

Record

Tables can be joined together to combine and subset 

data using join keys

Individual tables and fields are defined by a database 

schema (for Antelope seismic data, schema is css3.0)





What is a (Datascope) database?

Important idea:

Databases do not have to have all of the tables shown.

Datascope allows you to combine two databases 

containing different tables together into one larger 

database through a database descriptor file. 

m ga rd in e@s ockeye> m ore m y_da ta ba s e

#

s ch em a  cs s 3 .0

dbpa th  / h om e/ m ga rd in e/ {s ta t ion _db}:/ h om e/ m ga rd in e/ {or igin _db}

Results is a new database, called my_database, which 

contains the tables in station_db and origin_db



What to do with a database?

Locations of important databases (all on the Sun network):

AEIC/AVO Stations:

/iwrun/op/params/Stations/{master_stations}

AEIC Origins:

/Seis/catalogs/aeic/Total/{Total}

AVO Origins:

/Seis/Kiska4/picks/Total/{Total}

AEIC/AVO Waveforms:

/iwrun/op/db/archive/* (day files)



What to do with a database?
Antelope provides a graphical front-end for viewing and simple editing 

of databases : dbe

m ga rd in e@s ockeye> dbe m y_da ta ba s e

Each table in the databaseEach field in the tableEach record in the table



View > Arrange to see all possible fields of a table/view 

What to do with a database?



What to do with a database?
View > Arrange to see all possible fields of a table/view 



What to do with a database?

In practice, I find that two database operations are 

used more than any others:

Join: Merges two tables together using a field 

common to both (example: orid, arrid).  Result is 

called a “view”

Subset: Filters the values in a table (or view) 

based on user-specified conditions



What to do with a database?
View > Join to join the current view with another table

IMPORTANT NOTE:

Not all tables can be (correctly) joined together directly.  Order matters!

Example: You want all of the arrivals for a given origin.  Try opening the origin 

table and joining it with the arrival table.  Is the result what you expected?

Solution: You must join the tables through an intermediary table called Assoc



What to do with a database?
View > join Keys to see what field the current view will use to 

join with the other tables

Good join key (in general)

Bad join key



What to do with a database?
Subset: Filters the values in a table (or view) 

based on user-specified conditions



What to do with a database?
Subset: Filters the values in a table (or view) 

based on user-specified conditions

Say we want all origins with ML > 3

Entry window



What to do with a database?
Subset: Filters the values in a table (or view) 

based on user-specified conditions

View > Subset to apply the expression in the entry window

Say we want all origins with ML > 3

Note the total number of records in the current view



What to do with a database?
Subset: Filters the values in a table (or view) 

based on user-specified conditions

Note the total number of records in the current view

Say we want all origins with ML > 3

View > Subset to apply the expression in the entry window



What to do with a database?

The expressions allowed in the entry window are fairly high-level:

Logical expressions:

ml > 3

depth < 30

sta == ‘RSO’

lat > 60 && lat < 61 && lon > -156 && lon < -155

Pattern matching:

chan =~ /.*Z/

phase =~ /P|S/

Calculator:

distance(orig.lat, orig.lon, site.lat, site.lon) < (10/111.1)

See the Datascope: A tutorial pdf for more examples of expressions that you 

can use for subsetting



Antelope and Matlab
Rather than using a graphical interface like dbe, the Matlab interface (actually, 

almost all of the Datascope libraries) use a structure called a database pointer

Each pointer has four fields, with each field being filled in with an integer:

Database #

Table #

Field #

Record #

These numbers tell Antelope what database and view you are operating on, and 

where to find it.  It’s all a bit abstract, but in many ways most of the things you 

will do with these database pointers are very analogous to things that we’ve 

already done with dbe .

Since the easiest way to learn a program is to use it, the final portion of this 

presentation will cover two examples doing some basic analyses of catalog 

data using Matlab.

Where possible, I will also show the duality between doing things in Matlab and 

with dbe.



Example 1: AVO data

For this problem, I want to create a plot showing the cumulative number of 

earthquakes located at Redoubt over the last 10 years.

What steps will we need to do in order to accomplish this task?

1. Locate the AVO catalog

2. Find what database tables would be relevant to the task

3. Decide what constitutes an earthquake “at” Redoubt

4. Subset the data to only include what we want

5. Extract the data – what fields will we need?

6. Plot the data



Step 1: Locate the AVO Catalog

Found at /Seis/Kiska4/picks/Total/{Total} on the Sun network

The variable db is now a database 

pointer, with an entry in the database 

field, and NULL (-511) in the others.

This is equivalent to opening a 

database through dbe:

m ga rd in e@s ockeye> dbe 

/ Seis / Kis ka 4 / p icks / Tota l/ Tota l



Step 2: Find what database tables would be relevant to the task

We want the earthquake origins themselves, with no interest in arrivals, 

stations, or waveforms.  Therefore, the origin table is the only table of interest.

The dblookup command is the way 

for a user to fill in the pointer values.  

In this case, we want our pointer to 

point towards the origin table.

The variable db is now a database 

pointer, with an entry in the database 

and table fields, and NULL (-511) in 

the others.

This is equivalent to clicking on the 

origin table dbe.



Step 3:Decide what constitutes an earthquake “at” Redoubt

Step 4: Subset the data to only include what we want

There are two straightforward choices – creating a latitude/longitude bounding box, 

or use a radial distance from some point
The dbsubset command is the way for a 

user to subset a view.  

In this case, we want our view to only 

contain origins from 60.3-60.7 N and 

152.3-153 W (roughly corresponds to 

bounds on AVO’s seismicity plot for 

Redoubt).  Next, we subset to only 

include origins from the last 10 years.

The variable db is now a database 

pointer, with an entry in the database 

and a new value in the table field, and 

NULL (-511) in the others.

This is equivalent to typing in 

“lat>60.3&&lat<60.7&&lon>-153&&lon<-

152.3 && time> “May 1 1999”” in the 

entry window and clicking View > 

Subset



Step 5: Extract the data

Since we want to plot cumulative number of earthquakes verses time, we really 

only need the time field.
The dbgetv command is the way for 

a user to extract records from a view 

into Matlab variables.  

In this case, we want to extract all of 

the records from the time field in our 

view.

For any field that uses times, 

Antelope automatically extracts the 

values in epoch time.  The easiest 

way to convert this to a more 

Matlab-friendly format is through the 

strtime command.

This is equivalent to clicking View > 

Arrange, unchecking everything 

except the time field, then clicking on 

File > Save > Text separated by 

tabs, and then importing the text file 

into Matlab.  Quite a pain! 



Step 6:  Plot the data

We can plot the data by using a simple plot command with the time on the x-

axis and the cumulative number of events on the y-axis.  Changing the format 

of the axis from serial date format to a string format is done with datetick.



Example 2: AEIC data
Now let’s do a slightly more complicated example using AEIC data.  Say we want 

to know how many P-arrivals from ML>3 earthquakes in 2008 were seen at station 

COLA, and at what back-azimuth those arrivals came from. 

What steps will we need to do in order to accomplish this task?

1. Locate the 2008 AEIC earthquake catalog

2. Find what database tables would be relevant to the task

3. Join the tables that we need together

4. Subset the catalog to only include information that we want

5. Extract the data

6. Plot the data



Step 1: Locate the 2008 AEIC earthquake catalog

Found at /Seis/catalogs/aeic/Total/{aeic_2008} on the Sun network

The variable db is now a database 

pointer, with an entry in the database 

field, and NULL (-511) in the others.

This is equivalent to opening a 

database through dbe:

m ga rd in e@s ockeye> dbe

/ Seis / ca ta logs / a eic/ Tota l/ a eic_2008



Step 2: Find what database tables would be relevant to the task

We want the information about the earthquake origins (magnitude > 3), and information 

about the arrivals (back-azimuth of P-arrivals on COLA).  The origin information is stored 

in the origin table, and the back-azimuths are stored in the assoc table.

We will need to use dblookup twice, 

in order to get the pointer values for 

both the origin and assoc tables.

The variable db_origin is now a 

database pointer, with an entry in the 

database and table fields pointing to 

the origin table, and NULL (-511) in 

the others.

The variable db_assoc is now 

another database pointer, with an 

entry in the database and table fields 

pointing to the assoc table, and 

NULL (-511) in the others.



Step 3: Join the tables that we need together

The dbjoin command takes two 

database pointers and performs a 

join into a new view with a new 

database pointer.

The variable db is now a database 

pointer, with an entry in the database 

and a new value in the table field, 

and NULL (-511) in the others.

This is equivalent to opening the 

origin table in dbe, and then clicking 

on View > Join > Assoc



Step 4: Subset the catalog to only include the information that we want

We will need three distinct subsets: magnitudes > 3, only show P 

arrivals, and only show arrivals at station COLA.

This time will we combine all three 

subsets into one expression and then 

subset the view with the dbsubset

command.  

The variable db is now a database 

pointer, with an entry in the database 

and a new value in the table field, and 

NULL (-511) in the others.

This is equivalent to typing in “ml>3 && 

sta==“COLA” && phase=~/P/” in the 

entry window and clicking View > 

Subset



Step 5: Extract the data

Here we will extract two fields from 

our database: the seaz (station-to-

event azimuth, aka back-azimuth), 

and the orid (origin id numbers).

dbgetv supports extracting as many 

fields as you want (as long as they 

are present in the view, of course) 

into Matlab variables.

This is equivalent to clicking View > 

Arrange, unchecking everything 

except the seaz and orid fields, then 

clicking on File > Save > Text 

separated by tabs, and then 

importing the text file into Matlab.



Step 6:  Plot the data

We can plot the data by using the hist command, but since we are dealing with 

angular values, a better way would be by using the rose command, which plots 

a rose diagram (a histogram in polar coordinates).



Other Matlab/Antelope Tools

A few additional tools (not developed by BRTT) exist for additional 

manipulation of Antelope data with Matlab

Waveform – A Matlab object which allows for the importation and 

manipulation of waveform (time series) data into Matlab.

Download: http://www.mathworks.com/matlabcentral/fileexchange/23809

Help: 
http://www.giseis.alaska.edu/input/celso/matlabweb/waveform_suit/waveform.html

Correlation - A Matlab object built on top of Waveform which allows 

for the efficient calculation and plotting of cross-correlation values 

between waveforms.

Download: http://www.giseis.alaska.edu/Seis/EQ/tools/matlab

Help: Same link

http://www.mathworks.com/matlabcentral/fileexchange/23809
http://www.giseis.alaska.edu/input/celso/matlabweb/waveform_suit/waveform.html
http://www.giseis.alaska.edu/Seis/EQ/tools/matlab


Datascope: A Tutorial

http://www.brtt.com/docs/datascope.pdf

Antelope Toolbox for Matlab User’s Manual and Tutorial:

http://crs.inogs.it/antelope/doc/matlab/Antelope_Toolbox_for_Matlab.pdf

Other Helpful Links

http://www.brtt.com/docs/datascope.pdf
http://www.brtt.com/docs/datascope.pdf
http://www.brtt.com/docs/datascope.pdf
http://crs.inogs.it/antelope/doc/matlab/Antelope_Toolbox_for_Matlab.pdf

