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Getting Started

The BTManager utility controls the FC-250 Bluetooth module.

Getting Started

To start BT Manager:

1. Turn on the FC-250.
2. Press the Bluetooth icon in the system tray, and select Bluetooth
Manager from the pop-up menu.

AY start BlueTray

e Wednesday 4 Wednesday
January 07, 2009 4 January 07, 2009
—

o

G’) : On : On
@ Getting Started Getting Started
.?, Tap here to set owner information: Tap here to set owner information:

No unread messages

-
No unread messages

. No tasks

No tasks

n No upcoming appointments No ubcoming appointments

& =D

Live Search

&' Device unlocked

About...

Calendar Contacts Calendar Contacts

Figure 1. Starting Bluetooth Manager

3. If'the Bluetooth transmitter is switched off (The Bluetooth icon is
gray.), select Turn Transmitter On to turn on Bluetooth.
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Getting Acquainted

Getting Acquainted

Table 1 summarizes the screens and settings in BTManager.

Table 1. BTManager Screens

Description

Screen

Type of devices to detect

This screen displays types of
devices to discover. Once a device
type is selected, the Discovery
Wizard searches for those devices
when you tap Next.

A2 Bluetooth Manager ataEX

The Discovery Wizard is ready to search
for Bluetooth devices. Select the type of
Bluetooth devices that you would like to
discover and tap Next to begin the

®iny Shuetooth dovie)

O Computer

(O Phone

(O LAN/Network Access Point

O Peripheral

O Imaging

O Miscellaneous

O Unclassified

| < Back || Next > ‘

Device List

This screen displays all discovered
devices of a selected type. From
this list, you can choose a device to
add to your List of Favorite Devices
by tapping Next.

4Y Bluetooth Manager Padl PN 1 ¢

Device Name |Address

O 'JIMTPC3008 00:10:60:30:0e:6a
O 'JSVDELLSO 00:16:41:1a:b8:32
EQANKOHOIS 00:07:80:88:73:d5
O 'JMTPC3014 00:1b:dc:00:20:ef
Eg GSR2700 I... 08:00:17:20:49:97
|2|€3GPT-3000 ... 00:02:¢7:60:50:bb
[ & soot 00:21:9e:f6:cd:c4

Check the checkboxes next to the device
that you would like to save.

< Back || Next >
|
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Getting Acquainted

Table 1. BTManager Screens (Continued)

Description

Screen

List of Favorite Devices

This screen displays your preferred
Bluetooth-enabled devices. You can
use the Device Discovery wizard
option in the Tools menu or the
Bluetooth Devices screen to search
for Bluetooth-enabled devices
within range and save them to this
list for future connections.

¥ Bluetooth Manager o

636363

GPT-3000 GSR27001IS  ANKCHO1>
420763  NZH06190...

Device View Tools Help

My Bluetooth Device

This screen displays the internal
FC-250 Bluetooth module
information. On this screen, you
can set your preferences and choose
how to connect with other devices.

A% Bluetooth Manager Poedl N e 2K

My

TopcoR Bluetooth Device

Class (Major): Computer
&= Class (Minor): Palm
Device Name:  Pocket_PC

Address: 00:03:7a:38:1a:0b
BT Module: Internal Bluetooth

Authentication
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Getting Acquainted

Table 1. BTManager Screens (Continued)

Description Screen

Pairing

A2 Bluetooth Manager Podl S e D4

This screen displays when the FC-

. .. . oth G
250 is in pairing mode, and it I a
accepts a pairing request initiated Pairing
by a remote device. Tap Next to begin pairing Bluetooth

devices. Pairing creates a bond between
the computer and your Bluetooth device.
This process is only required once per
Bluetooth device.

About BTManager
&% Bluetooth Manager Qe EX
This screen displays version and
copyright information for
BTManager.

Bl
TOPCON

-
About

BtManager Version 2.28.1,
September 3, 2009

Copyright © 2006-2009

Topcon Positioning Systems
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Working with Bluetooth Manager

Working with
Bluetooth Manager

Before the FC-250 can pair with another Bluetooth-enabled device, it
must discover which devices are available within your coverage area.
You can use the Device Discovery wizard to search for any
Bluetooth-enabled device within range or a particular type of device,
and then save the device(s) to your Bluetooth Devices folder for
future connections.

&2 Bluetooth Manager ot E@X

B O @

GPT-3000 GSR27001IS  ANKOHO15
420763  NZH06190...

Device View Tools Help

Figure 2. List of Favorite Devices

Discovering Devices

To discover other Bluetooth-enabled devices within your coverage
area.

1. Tap Tools » Device Discovery.
The Discovery Wizard appears (Figure 3).
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Working with Bluetooth Manager

A2 Bluetooth Manager Podl S e D4

Bluetooth Device

TOPCON . N
Discovery

Tap Next to discover new Bluetooth
devices. Make sure the new devices are
on and in Discoverable mode.

T ——
Next >

Figure 3. Discovery Wizard

2. Tap Next to display a list of device types.

A% Bluetooth Manager e @X

The Discovery Wizard is ready to search
for Bluetooth devices. Select the type of
Bluetooth devices that you would like to
discover and tap Next to begin the

®[Any Bluetooth device]

O Computer

(O Phone

(O LAN/Network Access Point
(O Peripheral

O Imaging

O Miscellaneous

O Unclassified e
| < Back Next > ’

Figure 4. Device Categories

3. Choose a type of device to discover, and tap Next.

The Discovery Wizard searches for Bluetooth-enabled devices in
your coverage area and displays the icons of the devices it detects
on the Device List.

As device names and addresses are retrieved, the Device List
updates with detailed information (Figure 5 on page 7).
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Working with Bluetooth Manager

Once the Device List is populated, you can add any device from this
list to the List of Favorite Devices.

Adding to the List of Favorite Devices

The Device List displays all discovered Bluetooth-enabled devices in
your coverage area.

To add a device from the Device List to the List of Favorite Devices:
1. Select a device, and tap Next. You can choose more than one
device.

AY Bluetooth Manager (3} o & X

Device Name |Address |
[]idMTPC3008  00:10:60:30:0e:6a
O ‘JSVDELLSO 00:16:41:1a:b8:32
EQANKOHOIS 00:07:80:88:73:d5
[ idMTPC3014  00:1b:clc:00:20:ef
[v] 9 GSR27001... 08:00:17:20:48:97
[v] 9 GPT-3000 ... 00:02:c7:60:50:bb
s 00:21:9e:f6:cd:c4

Check the checkboxes next to the device
that you would like to save.

< Back g Next > ,

Figure 5. Select Device(s)

A confirmation message appears when the devices are
successfully added to the List of Favorite Devices.
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Working with Bluetooth Manager

2. Tap Finish to exit the Wizard and display the List of Favorite
Devices.

A% Bluetooth Manager S X

Success!

You have added 3 new device(s).
Tap Finish to exit.

Figure 6. Devices Added

To save time, you can save Bluetooth-enabled devices on the List
of Favorite Devices, so you do not have to rediscover it. You can
view devices by icon and name or by name and address.

' Bluetooth Manager

GPT-3000 GSR27001IS  ANKOHO1>
420763 NZH06190...

Device View Tools Help

Figure 7. List of Favorite Devices
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Working with Bluetooth Manager

To display the list of devices by name and address, tap
View » Details.

Device Name Address

9 GPT-3000 420763  00:02:¢7:60:50:bb
9 GSR2700 IS NZH... 08:00:17:20:49:97
QANKOHOIS 00:07:80:88:73:d5

( i D,
Device View Tools Help 1

Figure 8. Details on Bluetooth Devices

Viewing Device Properties

To view the properties of a device, select the device in the List of
Favorite Devices (Figure 7 on page 8), and tap Device » Properties.

&% Bluetooth Manager a4 @ X

Bluetooth Device

TOPCON .
Properties

9 Class (Major):  Unclassified
Class (Minor):

Device Name: 391-0814
Address: 00:03:7a:67:3a:13

Supported Services:
Positioning

Figure 9. Bluetooth Device Properties

The Bluetooth Device Properties screen displays major and minor
class identifiers, the name, and address of the selected device.
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Working with Bluetooth Manager

Deleting a Device from the List

To delete a device from the List of Favorite Devices:

1. Select the device, and tap Device » Delete.
A confirmation message appears.
2. Tap Yes to delete the device.

Device Name Address
9 GPT-3000 420763  00:02:¢7:60:50:bb

Bluetooth Manager

@ Confirm deletion of the
-~ device "GPT-3000 420763"?

G ]

%

r< [ — ; >
Device View Tools Help 1

Figure 10. Deleting a Device

Setting Device Preferences

The My Bluetooth Device screen (Figure 11 on page 11) displays
information about the internal FC-250 Bluetooth module. The
preferences you set on this screen determine how your FC-250 pairs
with and connects to remote devices.
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Working with Bluetooth Manager

To access the My Bluetooth Device screen, tap Device » My
Bluetooth Device.

&% Bluetooth Manager a¢cEd

My
ToPCES Bluetooth Device
Class (Major): Computer
£ Class (Minor): Palm

Device Name:  Pocket_PC
Address: 00:03:7a:38:1a:0b
BT Module: Internal Bluetooth

Authentication

Figure 11. My Bluetooth Device

My Bluetooth Device always displays the following information:
* Class (major and minor)

* Name (Other devices use this name to identify the FC-250.)
* Address

This screen also allows you to enable the following accessibility
options:

* Discoverable: allows other devices within range to find the
FC-250.

+ It is not necessary to enable this option when initiating a
connection from the FC-250 and for most dial-up
networking.

* When not in use, disable this option manually to save power.

* Authentication: authenticates the identity of other devices. Select
this option if you want to require a passkey to connect with
another Bluetooth enabled device. If either or both devices use
authentication, then a passkey must be entered. Once
Authentication is selected, the Passkey can be edited.
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Working with Bluetooth Manager

Typically, Topcon Bluetooth-enabled GPS receivers
do not require a PIN upon connection. If it is
necessary, however, the PIN (up to 16 characters)
can be set for a Topcon GPS receiver by BTCONF,
the Topcon Bluetooth module configuration
program.

g Topcon Total Stations require a PIN on connection.
NOTE Typically, the PIN value is set to “1111”. This value
can be changed.

BTManager allows the FC-250 to connect with other Bluetooth-
enabled devices using serial port or dial-up services. The connecting
device needs to support the service selected:

» SPP (Serial Port Profile): provides serial port connection with
peripheral Bluetooth-enabled devices, including GPS
receivers which normally do not require authentication.

* DUN (Dial-up Networking Profile): provides a standard to
access dial-up services over Bluetooth. The most common
scenario is using a mobile phone as a modem.

Pairing Bluetooth Devices

Communication connection between devices is possible by
exchanging the PIN (passkey) and the address. Once the
authentication is completed and the communication becomes
possible, these devices are considered confirmed, and will no longer
require any authentication for connection.

The List of Favorite Devices displays all connectable devices around
FC-250.
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Working with Bluetooth Manager

Paring is not necessary to connect with a Bluetooth
device without a passkey setup.

Procedures to connect with the Bluetooth device on the List of
Favorite Devices are described below.

1. To activate Pairing Mode, tap Device » Pair

A% Bluetooth Manager S @EX

EGPT-3000 420763 00:02:¢7:60:50:bb
ﬁ GSR2700 IS NZH... 08:00:17:20:4¢:97
QANKOHOIS 00:07:80:88:73:d5

D

Properties

Delete

My Bluetooth Device...

Exit

W >1
Device |View Tools Help

Figure 12. Device Menu - Pairing Enable

The Pairing screen appears to guide you through the pairing
process.
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Working with Bluetooth Manager

2. Tap Next to continue.
The Wizard searches for the other device.

Bluetooth Manager

&% Bluetooth Manager S EX

Bl th L
Pairing
Tap Next to begin pairing Bluetooth Device Name:  GPT-3000 420763

devices. Pairing creates a bond between Device Address: 00:02:¢7:60:50:bb
the computer and your Bluetooth device.

This process is only required once per
Bluetooth device. q

Pairing will be attempted with the
following device:

TOPCON

Please make sure the Bluetooth on the
device is enabled and will accept pairing.

Tap Next to continue...

g Next > P < Back g Next > F

Figure 13. Pairing with Remote device

When the Wizard discovers the other Bluetooth-enabled device,
you are prompted to enter a passkey (PIN) for authentication.
The same passkey must be entered on both devices to establish
authentication and pairing. Authentication is only required the
first time the two devices pair.

A2 Bluetooth Manager Podl S e D4

A% Bluetooth Manager o @EX

The following device requires a passkey: [ The following device requires a passkey: [a

GPT-3000 420763 P GPT-3000 420763

The same Bluetooth passkey is required
on each device. Please enter the passkeys
below and tap Next, or close the Wizard
denv the request.

Please enter the passkey below:

1111

The same Bluetooth passkey is required
on each device. Please enter the passkey
below and tap Next, or close the Wizard
denv the request.

Please enter the passkey below: I

| < Back || *

a1 2] 3] 415 6] 7 8] 210 - w[1]2]3]4)s]6]7]s]9]of-[=]«
TabJafw]e] ] ef yJu]i]o ] TebJafw]e] o] e]ylufifo]p]i]]
CAPJa|sfd]flglhlilk CAPJals|d]flaglh]i]k 4 4

shift | z [x[cfvibln[m], Shift) z | xJeJvibln]ml, ). J/]<
[o:} EI'R B A Wt~

[-]=]
ID,I[.I

B -

Figure 14. Enter Passkey (PIN)
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Working with Bluetooth Manager

3. Enter a passkey, and then tap Next.

4. If the passkey on the remote device is changed or revoked, an

error message appears. Tap OK to change the current passkey.

A% Bluetooth Manager St @@

The operation being
requested was not
performed because the user
has not been authenticated.

Source: Win32 API

Passkey length must be between 1 and 16
symbols.

Figure 15. Change Current Passkey
A congratulation message appears when the pairing is successful.
£¥ Bluetooth Manager  ¢? ¢ @ X

Success!

You are now paired to the following
device:

GPT-3000 420763

Tap the Finish button to exit the Wizard.

a

Figure 16. Successful Pairing

5. Tap Finish to exit the Wizard.
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